This project is read-only.

Can't see my movies

Jun 19, 2011 at 2:52 PM

I started using Serviio on WHS a week ago.  I can view my photos on both my Sony Bravia and my Samsung PN59D7000, but I can't see the movies. I navigate to the Serviio media folder, but it appears empty. Any suggestion?

Jun 19, 2011 at 4:31 PM

I have a Bravia, as well, and it is the main reason I adopted Serviio for myself. Three basic things to check.

First, make sure you have your movie folders shared in the Library & Presentation section of the console AND make sure that the folder is marked as having Video files to share (check the appropriate checkbox in the Shared Folder properties).

The second is to make sure you are trying to find the movies through the "Video" section of your TV/Blu-Ray menu. I have many time times found myself trying to find my movies or tv shows by first opening Serviio from the "Photo" or "Music" sections of the menu (called the XMB in the case of the Bravia). The TV or Blu-Ray will filter the list of media to show only the type of media selected. It will, however, still show the categories, which makes it very confusing. So, for example, if you click Music -> Serviio -> Video -> Movies, it will say there's nothing there. However, if you click Video -> Serviio -> Video -> Movies, they'll all be there.

Finally, make sure that you are not accidentally hiding the videos. In the Library & Presentation section of the Console, click on the Presentation Options button. Check to make sure that you haven't "Disabled" any of the videos sections, or at least not any of the "relevant" ones. 

Jun 19, 2011 at 5:59 PM

1) I appear to be sharing the right folders, and I can see them from WHS Serviio console.  I would send a screen shot of the console if I could figure out how to do it in this wiki.

2) I'm doing the navigation correctly.  The interface is different on the Bravia and the Samsung, but they both have same sort of path structure.  At the highest level, I've always been starting a Video.  They both have the same behavior.  When I click Video -> Serviio -> Video -> Folders I see the two sub-folders that I have shared, but when I click either sub-folder Movies or Family both are empty.  Again, I can see photos by navigating Photo -> Serviio -> Photo -> 1985, etc.

3) All Category/Visibility options are "Display Category".  I think that's the default.

Here's an interesting bit of info.  I saw my home movies on the Bravia briefly the first day I set Serviio up (MPG and AVI formats).  I never saw the movies (M4V format).  I've never seen anything on the Samsung.  While I was messing with the Samsung, I somehow lost the Bravia.  At any rate, I can't see any movies today on any device.



Jun 19, 2011 at 6:30 PM

That really is a strange one. I was going to have you look at the file types, but knowing that your M4V's aren't showing...well, that's what most of my movies are.

Try this:

1) Make sure that the folders are set up to "Scan for File Additions and Updates." This, along with the media type (Video/Music/Photo) is a checkbox on the folder options dialog.

2) Make sure that the library itself is set to "Keep Library Automatically Updated" and to "Search for Updates to Currently Shared Files."

3) Then try forcing the library to update by clicking the Force Update button. Wait for the library status to report "Idle" and try your TV again.

If this fails, try removing one of your shared video folders and re-adding it. This shouldn't be necessary, but maybe:

1) Remove the folder (don't worry, it's just removing if from Serviio, not from your server).

2) Force a library update.

3) Re-add the folder (again make sure to check Video and "Scan for File Additions and Updates").

4) Force a library update.

If this fails, I may need to send you to the Serviio help forums at http://forum.serviio.org for some more advanced help.

Jun 19, 2011 at 10:12 PM

Looks like we got a fix.

1) Was set.  I did play with these setting a week ago, but made sure they were back at the default.

2) Was set. I never changed these settings.

3, and then 1a, 2a, 3a, and 4a)   Here's a problem. I could not"Force Update" because it never stoped updating.  It's been updating since last week. I almost mentioned this in my second post.  It never got to Idle.  I removed the movie folders (Movies and Family).  It still would not stop updating ( >5min).  I tried to remove the last folder, Photos.  It would not disappear from the console.  I restarted the server.  Photos was still there, but it was now "Idle".  I tried to remove it again.  This time it disappeared.  I again restarted the server.  I added the Movie folder with only two files (1- M4V and 1-MPG).  After about 15 seconds, it got to Idle.  The "Retrieve Descriptive Metadata" was unchecked.  I checked "Retrieve Descriptive Metadata" and Forced Update again. I took about 30 second to finish.  The two files were then now visible and playable from both Sony and Samsung. I added 10 more M4V files. After Serviio got to Idle, they are all visible and play.  I'll move the rest of the files over.  I have high confidence they will play. 

I actually did something like this last week, but I was not as careful and slow as today. I didn't notice when it was "Updating" and "Idle".

Thanks. If I can provide any data to help move from Beta to full release, I will be glad to help.  I'm going to stick with WHS-1 for awhile because of the Drive Extender.  I'd love to have a rock solid Serviio running on it.

Have nice day.

Apr 30, 2013 at 8:35 PM
Keep in mind a path change can confuse Serviio server. I unplugged the external hard drive I had my movies on for a few days, upon replugging it, it went from d: to g: (ie. d:\Movies\General_Movies to g:\Movies\General_Movies) It will still allow you to navigate through the folders, but you will see Empty folders. So you either need to delete and rethread the folders, or go into windows and rename the drive letter back to D: